5. Enter the
neighbor
ipv6-address
update-source
command to specify an interface.
device(config-bgp-router)# neighbor fe80:4398:ab30:45de::1 update-source ethernet 1/3/1
6. Enter the
address-family
command and specify the
ipv6
and
unicast
keywords to enter IPv6 address family configuration
mode.
device(config-bgp-router)# address-family ipv6 unicast
7. Enter the
neighbor
ipv6-address
activate
command to enable the exchange of information with the neighbor.
device(config-bgp-ipv6u)# neighbor fe80:4398:ab30:45de::1 activate
8. Enter the
neighbor
ipv6-address
route-map
command and specify the
out
keyword to apply a route map to outgoing routes.
device(config-bgp-ipv6u)# neighbor fe80:4398:ab30:45de::1 route-map out myroutemap
9. Enter the
exit
command until you return to global configuration mode.
device(config-bgp-ipv6u)# exit
10. Enter the
route-map
name
permit
command to define the route map and enter route map configuration mode.
device(config)# route-map myroutemap permit 10
11. Enter the
set ipv6 next-hop
command and specify an IPv6 address to set the IPv6 address of the next hop.
device(config-routemap myroutemap)# set ipv6 next-hop 2001::10
The following example configures a neighbor using a link-local address and configures a route map to set up a global next hop for
packets destined for the neighbor.
device# configure terminal
device(config)# router bgp
device(config-bgp-router)# local-as 1000
device(config-bgp-router)# neighbor fe80:4398:ab30:45de::1 remote-as 1001
device(config-bgp-router)# neighbor fe80:4398:ab30:45de::1 update-source ethernet 1/3/1
device(config-bgp-router)# address-family ipv6 unicast
device(config-bgp-ipv6u)# neighbor fe80:4398:ab30:45de::1 activate
device(config-bgp-ipv6u)# neighbor fe80:4398:ab30:45de::1 route-map out myroutemap
device(config-bgp-ipv6u)# exit
device(config)# route-map myroutemap permit 10
device(config-route-mapmyroutemap)# set ipv6 next-hop 2001::10
Configuring BGP4+ peer groups
A peer group can be created and neighbor IPv6 addresses can be associated with the peer group. The peer group is then activated in the
IPv6 address family configuration mode.
1. Enter the
configure terminal
command to access global configuration mode.
device# configure terminal
2. Enter the
router bgp
command to enable BGP routing.
device(config)# router bgp
3. Enter the
local-as
command to configure the autonomous system number (ASN) in which your device resides.
device(config-bgp-router)# local-as 1000
Configuring BGP4+
FastIron Ethernet Switch Layer 3 Routing
53-1003627-04
485
Summary of Contents for FastIron SX 1600
Page 2: ...FastIron Ethernet Switch Layer 3 Routing 2 53 1003627 04 ...
Page 16: ...FastIron Ethernet Switch Layer 3 Routing 16 53 1003627 04 ...
Page 20: ...FastIron Ethernet Switch Layer 3 Routing 20 53 1003627 04 ...
Page 142: ...FastIron Ethernet Switch Layer 3 Routing 142 53 1003627 04 ...
Page 150: ...FastIron Ethernet Switch Layer 3 Routing 150 53 1003627 04 ...
Page 200: ...FastIron Ethernet Switch Layer 3 Routing 200 53 1003627 04 ...
Page 214: ...FastIron Ethernet Switch Layer 3 Routing 214 53 1003627 04 ...
Page 350: ...FastIron Ethernet Switch Layer 3 Routing 350 53 1003627 04 ...
Page 476: ...FastIron Ethernet Switch Layer 3 Routing 476 53 1003627 04 ...
Page 588: ...FastIron Ethernet Switch Layer 3 Routing 588 53 1003627 04 ...