# Create VLAN 20.
<Quidway>
system-view
[Quidway]
sysname Switch
[Switch]
vlan 20
[Switch-vlan20]
quit
# Configure the type of Eth0/0/1 as access and GE0/0/2 as trunk, and add Eth0/0/1 and
GE0/0/2 to VLAN 20.
[Switch]
interface ethernet0/0/1
[Switch-Ethernet0/0/1]
port link-type access
[Switch-Ethernet0/0/1]
port default vlan 20
[Switch-Ethernet0/0/1]
quit
[Switch]
interface gigabitethernet0/0/2
[Switch-GigabitEthernet0/0/2]
port link-type trunk
[Switch-GigabitEthernet0/0/2]
port trunk allow-pass vlan 20
[Switch-GigabitEthernet0/0/2]
quit
# Create VLANIF 20 and assign IP address 20.20.20.1/24 to it.
[Switch]
interface vlanif 20
[Switch-Vlanif20]
ip address 20.20.20.1 24
[Switch-Vlanif20]
quit
NOTE
Assign network segment address 20.20.20.2/24 to the interface connecting the router and Switch. The
details are not mentioned here.
Step 2
Create an ACL.
# Create Layer 2 ACL 4000 on the Switch to match the packets with the source MAC address
as 0000-0000-0003.
[Switch]
acl 4000
[Switch-acl-L2-4000]
rule permit source-mac 0000-0000-0003 ffff-ffff-ffff
[Switch-acl-L2-4000]
quit
Step 3
Create a traffic classifier.
Create traffic classifier
c1
on the Switch with ACL 4000 as the matching rule.
[Switch]
traffic classifier c1
[Switch-classifier-c1]
if-match acl 4000
[Switch-classifier-c1]
quit
Step 4
Create a traffic behavior.
# Create traffic behavior
b1
on the Switch and configure the traffic statistics action.
[Switch]
traffic behavior b1
[Switch-behavior-b1]
statistic enable
[Switch-behavior-b1]
quit
Step 5
Create a traffic policy and apply it to an interface.
# Create traffic policy
p1
on the Switch and bind the traffic classifier to the traffic behavior in
the traffic policy.
[Switch]
traffic policy p1
[Switch-trafficpolicy-p1]
classifier c1 behavior b1
[Switch-trafficpolicy-p1]
quit
Apply traffic policy
p1
to Eth0/0/1.
[Switch]
interface ethernet0/0/1
[Switch-Ethernet0/0/1]
traffic-policy p1 inbound
S3700HI Ethernet Switches
Configuration Guide - QoS
1 Class-based QoS Configuration
Issue 01 (2012-03-15)
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
50