host1(config)#
interface gigabitEthernet 1/1
host1(config-subif)#
l2vpn l2vpnB local-site-id 2 remote-site-id 4
host1(config-if)#
exit
!
! Configure a loopback interface on PE 1 and assign it an IP address.
host1(config)#
interface loopback 0
host1(config-if)#
ip address 10.1.1.1 255.255.255.255
host1(config-if)#
exit
!
! Assign the router ID for PE 1 using the IP address of the loopback interface.
host1(config)#
ip router-id 10.3.3.3
!
! Configure BGP signaling.
host1(config)#
router bgp 738
host1(config-router)#
neighbor 10.1.1.1 remote-as 738
host1(config-router)#
neighbor 10.1.1.1 update-source loopback 0
host1(config-router)#
neighbor 10.1.1.1 next-hop-self
host1(config-router)#
address-family l2vpn signaling
host1(config-router-af)#
neighbor 10.1.1.1 activate
host1(config-router-af)#
neighbor 10.1.1.1 next-hop-self
host1(config-router-af)#
exit-address-family
host1(config-router)#
address-family vpws l2vpnA
host1(config-router-af)#
exit-address-family
host1(config-router)#
address-family vpws l2vpnB
host1(config-router-af)#
exit-address-family
!
! Enable MPLS on the default virtual router.
host1(config)#
mpls
! Configure ATM core-facing interface 2/0.100 between PE 1 and the P router,
host1(config)#
interface atm 2/0.100
host1(config-subif)#
atm pvc 100 1 100 aal5snap 0 0 0
! and assign it an IP address.
host1(config-subif)#
ip address 192.168.5.5 255.255.255.0
!
! Enable MPLS, LDP, and topology-driven LSPs on the core-facing interface.
host1(config-subif)#
mpls
host1(config-subif)#
mpls ldp
host1(config-subif)#
exit
Configuration on PE 2 (Remote PE Router)
Use the following commands on the remote PE router (PE 2) to configure the VPWS
topology shown in Figure 134 on page 666.
! Configure VPWS instance l2vpnA. The route target (100:1)
! matches the route target configured for l2vpnA on PE 1.
host2(config)#
l2vpn l2vpnA encapsulation-type ethernet
host2(config)#
l2vpn l2vpnA site-range 10
host2(config)#
l2vpn l2vpnA site-name chicago site-id 3
host2(config)#
l2vpn l2vpnA rd 100:11
host2(config)#
l2vpn l2vpnA route-target both 100:1
host2(config)#
l2vpn l2vpnA control-word
host2(config)#
l2vpn l2vpnA sequencing
!
! Configure VPWS instance l2vpnB. The route target (100:2)
668
■
VPWS Configuration Example
JUNOSe 11.1.x BGP and MPLS Configuration Guide
Summary of Contents for BGP
Page 6: ...vi ...
Page 8: ...viii JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Page 37: ...Part 1 Border Gateway Protocol Configuring BGP Routing on page 3 Border Gateway Protocol 1 ...
Page 38: ...2 Border Gateway Protocol JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Page 234: ...198 Monitoring BGP JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Page 236: ...200 Multiprotocol Layer Switching JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Page 542: ...506 Monitoring BGP MPLS VPNs JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Page 544: ...508 Layer 2 Services Over MPLS JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Page 610: ...574 Virtual Private LAN Service JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Page 624: ...588 VPLS References JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Page 680: ...644 Virtual Private Wire Service JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Page 724: ...688 Monitoring MPLS Forwarding Table for VPWS JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Page 725: ...Part 6 Index Index on page 691 Index 689 ...
Page 726: ...690 Index JUNOSe 11 1 x BGP and MPLS Configuration Guide ...