Procedure
Step 1
Configure the VLAN for each interface so that the devices can communicate with each other.
<Quidway>
system-view
[Quidway]
sysname Switch
[Switch]
vlan batch 2 5 6
[Switch]
interface gigabitethernet0/0/1
[Switch-GigabitEthernet0/0/1]
port link-type trunk
[Switch-GigabitEthernet0/0/1]
port trunk allow-pass vlan 2 5 6
[Switch-GigabitEthernet0/0/1]
quit
[Switch]
interface gigabitethernet0/0/2
[Switch-GigabitEthernet0/0/2]
port link-type trunk
[Switch-GigabitEthernet0/0/2]
port trunk allow-pass vlan 2 5 6
[Switch-GigabitEthernet0/0/2]
quit
[Switch]
interface gigabitethernet0/0/3
[Switch-GigabitEthernet0/0/3]
port link-type trunk
[Switch-GigabitEthernet0/0/3]
port trunk allow-pass vlan 2 5 6
[Switch-GigabitEthernet0/0/3]
quit
Step 2
Configure priority mapping based on simple traffic classification.
# Create DiffServ domain
ds1
, map packets of 802.1p priorities being 6, 5, and 2 to PHBs CS6,
EF, and AF2, and color packets as green, yellow, and red.
[Quidway]
sysname Switch
[Switch]
diffserv domain ds1
[Switch-dsdomain-ds1]
8021p-inbound 6 phb ef green
[Switch-dsdomain-ds1]
8021p-inbound 5 phb af3 yellow
[Switch-dsdomain-ds1]
8021p-inbound 2 phb af1 red
[Switch-dsdomain-ds1]
quit
# Bind incoming interface GE 0/0/3 on the Switch to DiffServ domain
ds1
.
[Switch]
interface gigabitethernet0/0/3
[Switch-GigabitEthernet0/0/3]
trust upstream ds1
[Switch-GigabitEthernet0/0/3]
trust 8021p inner
[Switch-GigabitEthernet0/0/3]
quit
Step 3
Configure congestion avoidance.
# Create drop profile
wred1
on the Switch and set parameters of packets of three colors.
[Switch]
drop-profile wred1
[Switch-drop-wred1]
color green low-limit 80 high-limit 100 discard-percentage 10
[Switch-drop-wred1]
color yellow low-limit 60 high-limit 80 discard-percentage 20
[Switch-drop-wred1]
color red low-limit 40 high-limit 60 discard-percentage 40
[Switch-drop-wred1]
quit
# Apply drop profile
wred1
on outgoing interfaces GE 0/0/1 and GE 0/0/2 of the Switch.
[Switch]
interface gigabitethernet0/0/1
[Switch-GigabitEthernet0/0/1]
qos wred wred1
[Switch-GigabitEthernet0/0/1]
qos queue 5 wred wred1
[Switch-GigabitEthernet0/0/1]
qos queue 3 wred wred1
[Switch-GigabitEthernet0/0/1]
qos queue 1 wred wred1
[Switch-GigabitEthernet0/0/1]
quit
[Switch]
interface gigabitethernet0/0/2
[Switch-GigabitEthernet0/0/2]
qos wred wred1
[Switch-GigabitEthernet0/0/2]
qos queue 5 wred wred1
[Switch-GigabitEthernet0/0/2]
qos queue 3 wred wred1
[Switch-GigabitEthernet0/0/2]
qos queue 1 wred wred1
[Switch-GigabitEthernet0/0/2]
quit
Step 4
Configure congestion management.
# Set scheduling parameters of queues of different CoS on outgoing interfaces GE 0/0/1 and
GE 0/0/2 of the Switch.
S3700HI Ethernet Switches
Configuration Guide - QoS
3 Congestion Avoidance and Congestion Management
Configuration
Issue 01 (2012-03-15)
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
99