1-21
Cisco ASA Series CLI Configuration Guide
Chapter 1 Configuring OSPF
Configuring OSPFv3
ipv6 ospf encryption
{
ipsec spi
spi
esp
encryption-algorithm
[[
key-encryption-type
]
key
]
authentication-algorithm
[[
key-encryption-type
]
key
|
null
}
Example:
hostname(config-if)# interface
GigabitEthernet3/2.200
vlan 200
nameif outside
security-level 100
ip address 10.20.200.30 255.255.255.0
standby 10.20.200.31
ipv6 address 3001::1/64 standby 3001::8
ipv6 address 6001::1/64 standby 6001::8
ipv6 enable
ospf priority 255
ipv6 ospf cost 100
ipv6 ospf 100 area 10 instance 200
ipv6 ospf encryption ipsec spi 1001 esp
null sha1
123456789A123456789B123456789C123456789D
Specifies the encryption type for an interface. The
ipsec
keyword
specifies the IP security protocol. The
spi
spi
keyword-argument
pair specifies the security policy index, which must be in the
range of 256 to 42949667295 and entered as a decimal. The
esp
keyword specifies the encapsulating security payload. The
encryption-algorithm
argument specifies the encryption
algorithm to be used with ESP. Valid values include the following:
•
aes-cdc—Enables AES-CDC encryption.
•
3des—Enables 3DES encryption.
•
des—Enables DES encryption.
•
null—Specifies ESP with no encryption.
The
key-encryption-type
argument can be one of the following
two values:
•
0—The key is not encrypted.
•
7—The key is encrypted.
The
key
argument specifies the number used in the calculation of
the message digest. The number is 32 hexadecimal digits (16
bytes) long. The size of the key depends on the encryption
algorithm used. Some algorithms, such as AES-CDC, allow you
to choose the size of the key. The
authentication-algorithm
argument specifies the encryption authentication algorithm to be
used, which can be one of the following:
•
md5—Enables message digest 5 (MD5).
•
sha1—Enables SHA-1.
The
null
keyword overrides area encryption.
Note
If OSPFv3 encryption is enabled on an interface and a
neighbor is on different area (for example, area 0), and
you want the ASA to form adjacencies with that area, you
must change the area on the ASA. After you have changed
the area on the ASA to 0, there is a delay of two minutes
before the OSPFv3 adjacency comes up.
ipv6 ospf flood-reduction
Example:
hostname(config-if)# interface
GigabitEthernet3/2.200
vlan 200
nameif outside
security-level 100
ip address 10.20.200.30 255.255.255.0
standby 10.20.200.31
ipv6 address 3001::1/64 standby 3001::8
ipv6 address 6001::1/64 standby 6001::8
ipv6 enable
ospf priority 255
ipv6 ospf cost 100
ipv6 ospf 100 area 10 instance 200
ipv6 ospf flood reduction
Specifies the flood reduction of LSAs to the interface.
Command
Purpose
Summary of Contents for 5505 - ASA Firewall Edition Bundle
Page 28: ...Glossary GL 24 Cisco ASA Series CLI Configuration Guide ...
Page 61: ...P A R T 1 Getting Started with the ASA ...
Page 62: ......
Page 219: ...P A R T 2 Configuring High Availability and Scalability ...
Page 220: ......
Page 403: ...P A R T 2 Configuring Interfaces ...
Page 404: ......
Page 499: ...P A R T 2 Configuring Basic Settings ...
Page 500: ......
Page 533: ...P A R T 2 Configuring Objects and Access Lists ...
Page 534: ......
Page 601: ...P A R T 2 Configuring IP Routing ...
Page 602: ......
Page 745: ...P A R T 2 Configuring Network Address Translation ...
Page 746: ......
Page 845: ...P A R T 2 Configuring AAA Servers and the Local Database ...
Page 846: ......
Page 981: ...P A R T 2 Configuring Access Control ...
Page 982: ......
Page 1061: ...P A R T 2 Configuring Service Policies Using the Modular Policy Framework ...
Page 1062: ......
Page 1093: ...P A R T 2 Configuring Application Inspection ...
Page 1094: ......
Page 1191: ...P A R T 2 Configuring Unified Communications ...
Page 1192: ......
Page 1333: ...P A R T 2 Configuring Connection Settings and QoS ...
Page 1334: ......
Page 1379: ...P A R T 2 Configuring Advanced Network Protection ...
Page 1380: ......
Page 1475: ...P A R T 2 Configuring Modules ...
Page 1476: ......
Page 1549: ...P A R T 2 Configuring VPN ...
Page 1550: ......
Page 1965: ...P A R T 2 Configuring Logging SNMP and Smart Call Home ...
Page 1966: ......
Page 2059: ...P A R T 2 System Administration ...
Page 2060: ......
Page 2098: ...1 8 Cisco ASA Series CLI Configuration Guide Chapter 1 Troubleshooting Viewing the Coredump ...
Page 2099: ...P A R T 2 Reference ...
Page 2100: ......